Clutch Issues (re-call) - Page 4 - 2018 Textron Havoc X Forum
 17Likes
Reply
 
Thread Tools
post #31 of 37 (permalink) Old 10-17-2018, 09:38 AM
Junior Member
 
Bigshoe327's Avatar
 
Join Date: Oct 2018
Posts: 10
Quote:
Originally Posted by Rydag View Post
Well we have another twist to the clutch issue. It seems that my unit was one of the ones that got the upgrade at the factory. (Serial number) So why did it grind when shifting. It turns out that the shifting cable was not adjusted correctly, they adjusted it and it seems to work fine now. Going for a test run tonight.
Man I keep seeing these QA issues with Textron, what's up??
Woodsman likes this.
Bigshoe327 is offline  
post #32 of 37 (permalink) Old 11-18-2018, 04:45 PM
Junior Member
 
Join Date: Nov 2018
Posts: 3
Where are these TSB's and Recall's documented? How can we know a Dealership, for profit at $90 an hour for labor. is giving me the truth? I am having these exact problems...
Woodsman is offline  
post #33 of 37 (permalink) Old 11-18-2018, 08:21 PM
Senior Member
 
Join Date: Jun 2018
Posts: 311
Garage
Havenít had a problem with the clutch or belt. And hope that I donít. 👍
Cadydid is offline  
post #34 of 37 (permalink) Old 11-21-2018, 05:58 AM
Junior Member
 
Join Date: Nov 2018
Posts: 4
Mine will grind a little, but I have found that coming to a complete stop and letting the machine idle down will eliminate that
Cadydid likes this.
cdavis1963 is offline  
post #35 of 37 (permalink) Old 11-21-2018, 06:44 PM
Senior Member
 
Join Date: Jun 2018
Posts: 311
Garage
Quote:
Originally Posted by cdavis1963 View Post
Mine will grind a little, but I have found that coming to a complete stop and letting the machine idle down will eliminate that
Yeah, any attempt to shift while rpms are higher than idle and it will grind. But otherwise works very well. 👍
Rydag likes this.
Cadydid is offline  
post #36 of 37 (permalink) Old 01-17-2020, 07:26 PM
Member
 
Join Date: Mar 2019
Posts: 30
gears grinding

I know it's a little late, but I saw in EPI / Erlandson performance, newsletter sent to me that stated hard shifting geargrinding could occur if primary to secondary aligment wasn't correct.That explains why dealer probably removed or added a shim behind secondary.
mnplumber likes this.
JJBUR59 is offline  
post #37 of 37 (permalink) Old 10-16-2020, 06:47 PM
Junior Member
 
Join Date: Oct 2020
Posts: 2
I am a new 2018 Havoc X owner. I am having the gear grinding problem. I've been told to drive from high speed to idle for 50 to 100 miles to clean up the belt to clutch surfaces. It has been setting unused for some time. Just wondering if anyone has any new information on this problem. Thanks in advance.
bobconn is offline  
Reply

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

 
For the best viewing experience please update your browser to Google Chrome