Water Pump - Page 2 - 2018 Textron Havoc X Forum
 5Likes
Reply
 
Thread Tools
post #11 of 18 (permalink) Old 10-28-2020, 11:06 PM
Senior Member
 
Join Date: Jun 2018
Posts: 328
Garage
Quote:
Originally Posted by Lx700kev View Post
Is that the passenger side of the engine that leaks? Mine leaks too.
Yes, passenger side. There is also a rear diff vent hose that runs over there too and can expel a little of that when hot too.
Cadydid is offline  
post #12 of 18 (permalink) Old 03-08-2021, 09:31 AM Thread Starter
Member
 
Join Date: Sep 2019
Posts: 32
Well since I got it back I've maybe put 100 miles on it. Took it out to gather up a couple trail cameras Saturday while there was a break in the weather....guess what????????? Leaking again. Gonna get ahold of the dealer today and see if they are going to stand behind the work they did just a few months ago.
Rider300 is offline  
post #13 of 18 (permalink) Old 03-31-2021, 08:06 AM Thread Starter
Member
 
Join Date: Sep 2019
Posts: 32
Apparently it was 409 miles. They won't cover it.
Rider300 is offline  
post #14 of 18 (permalink) Old 04-01-2021, 06:29 PM
Member
 
Join Date: Aug 2020
Posts: 43
My leaks AF too! 391 Miles
NVHunter is offline  
post #15 of 18 (permalink) Old 04-28-2021, 11:03 PM
Junior Member
 
Join Date: Sep 2019
Location: Ontario
Posts: 6
I had the same issue a few weeks ago. I have a little over 2k on my machine. It was an expensive day as I noticed it leaking about 2 hours after my belt went and had to be replaced on the side of the trail!

Anyhow the dealer said it was a known issue as there was an official notice sent to dealers and it was a different seal they installed now.

Not a fan of them knowing about this and not being willing to cover at least a part of the cost. I'll chalk this up to the 'all machines have issues' and move on because I do really like this machine.
Cadydid likes this.
dont73 is offline  
post #16 of 18 (permalink) Old 05-11-2021, 09:43 AM
Junior Member
 
premix5150's Avatar
 
Join Date: Oct 2020
Posts: 3
Question Plug?

I have two of the Havoc x's the first one water pump was done by dealer as part of recall, second one done by myself, pump went out due to me not purging the system well enough after installing a heater.(duh). The first one started leaking again and of course after talking to Webber once they get hot they are toast, so get new pump installed in that one just to have it still leak, come to find out out after a pain staking cotorsion act discovered it was a cracked antifreeze hose plug located behind the oil filter. Just something to check hope it helps someone out. Does anyone know what that port would be for?
premix5150 is offline  
post #17 of 18 (permalink) Old 05-19-2021, 02:42 PM
Senior Member
 
Join Date: Jun 2018
Posts: 328
Garage
Quote:
Originally Posted by premix5150 View Post
I have two of the Havoc x's the first one water pump was done by dealer as part of recall, second one done by myself, pump went out due to me not purging the system well enough after installing a heater.(duh). The first one started leaking again and of course after talking to Webber once they get hot they are toast, so get new pump installed in that one just to have it still leak, come to find out out after a pain staking cotorsion act discovered it was a cracked antifreeze hose plug located behind the oil filter. Just something to check hope it helps someone out. Does anyone know what that port would be for?
Do t know what that port is for but sounds like something to check. Thanks for sharing.
Cadydid is offline  
post #18 of 18 (permalink) Old 05-20-2021, 09:20 AM
Junior Member
 
premix5150's Avatar
 
Join Date: Oct 2020
Posts: 3
answer to plug

Talked to Randy at Weber and this motor is used in some snowmobiles overseas called Tungus and the have an option for a external heating source, so apparently the heater makers for this machine do not know this because it would be a better option than having to splice both coolant lines.
Cadydid likes this.
premix5150 is offline  
Reply

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Forum Replies Last Post
Hello From Alaska TintedSnow New Member Introductions 5 07-24-2020 05:09 PM
Water in PTO Aero9k 2018+ Havoc X Complaints, Issues and Problems 5 10-17-2019 09:14 AM
Water Goofyt Textron Havoc X General Discussion 0 07-31-2019 07:43 AM
Havoc X electrical water problems Rhiggy1985 2018+ Havoc X Complaints, Issues and Problems 1 04-22-2019 10:35 PM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

 
For the best viewing experience please update your browser to Google Chrome